2016年11月20日,星期日

如何在Ubuntu上安装Appium

在本文中,我们将逐步在Ubuntu系统上安装appium。因此,让我们着手开始安装。


注意-如果通过SUDO安装,Appium会引发错误,因此通过npm安装Appium


1.要通过npm安装Appium,您需要 node.js和npm 0.12或更高。


2.要安装没有sudo的node.js和appium,我们使用linuxbrew。

3.要安装linuxbrew,这些是依赖项

    Ruby 1.8.6 or newer
    GCC 4.2 or newer
   Git 1.7.12.4或更高版本
   Linux 2.6.16或更高版本
   64位x86或32位ARM平台

4.使用以下命令安装Ruby

sudo apt-get install build-essential curl git m4 python-setuptools ruby​​ texinfo libbz2-dev libcurl4-openssl-dev libexpat-dev libncurses-dev zlib1g-dev


5.使用以下命令安装Linux Brew

红宝石-e“$(curl -fsSL
//raw.githubusercontent.com/Homebrew/linuxbrew/go/install)"



6.设置冲泡路径

第一类 须藤gedit.bashrc 在终端 并将以下内容复制到中。bashrc file.export
 
PATH =“ $ HOME / .linuxbrew / bin:$ PATH” exportMANPATH =“ $ HOME / .linuxbrew / share / man:$ MANPATH” export INFOPATH =“ $ HOME / .linuxbrew / share / info:$ INFOPATH”



7。安装节点:打开新终端并复制命令,然后按Enter
酿造更新
brew安装节点
Brew链接节点
 


8,使用以下命令最终安装Appium
npm install -g appium

9.让我们检查安装是否成功。打开终端,输入“ appium”,然后按Enter。您应该在终端中看到类似的内容

信息:欢迎使用Appium v​​1.4.12(版本8db2d00b9afcf2c50a09a80a2e8d56b05a902caf)
信息:Appium REST HTTP接口侦听器从0.0.0.0:4723开始
信息:控制台LogLevel:调试

2条评论:

  1. 嗨,我在执行命令后进入了第七步"brew link node". I'被告知以下错误。
    -------------------------------------------------
    amrutha @ amrutha-Inspiron-3558:~$ Brew链接节点
    错误:没有这样的桶:/home/amrutha/.linuxbrew/Cellar/node
    amrutha @ amrutha-Inspiron-3558:
    -----------------------------------

    您能帮忙解决这个问题吗,谢谢

    回复删除
  2. It'一篇不错的文章,您在这里分享了有关"如何在Ubuntu上安装Appium"。对于希望以可承受的价格购买此服务的人,您的文章非常有用。感谢您在这里分享这篇文章。 Ubuntu设置静态IP

    回复删除