2016年11月20日星期日

如何在Ubuntu上安装Appium

在这篇文章中,我们将在Ubuntu系统上逐步安装Appium。所以让我们到达点并开始安装。


注意 - 如果通过sudo安装,请通过npm安装appium


1.通过您需要的NPM安装Appium node.js和npm 0.12或更高。


2.在没有sudo的情况下安装node.js和appium我们使用linuxbrew。

3.安装LinuxBrew这些是依赖项

    Ruby 1.8.6 or newer
    GCC 4.2 or newer
   Git 1.7.12.4或更新
   Linux 2.6.16或更新
   64位X86或32位臂平台

4.使用以下命令安装Ruby

sudo apt-get安装build-ender rupl git m4 python-setuptools ruby​​ texinfo libbz2-dev libcurl4-openssl-dev libexpat-dev libncurses-dev zlib1g-dev


5.使用以下命令安装Linux酿造

Ruby -e.“$(curl -fsSL
//raw.githubusercontent.com/Homebrew/linuxbrew/go/install)"



6.设置啤酒的路径

首先 sudo gedit.bashrc. in terminal 并复制下面的。Bashrc file.export.prosport.
 
path =“$ home / .linuxbrew / bin:$ path”exportmanpath =“$ home / .linuxbrew / share / man:$ manpath”导出infopath =“$ home / .linuxbrew / share / Info:$ InfoPath”



7.install节点:打开新终端并复制命令并按Enter键
酿造更新
BREW安装节点
BREW链接节点
 


8.最后使用以下命令安装Appium
npm install -g appium

9.重接安装是否成功。打开终端并键入“Appium”并点击Enter.You应该在终端看到这样的东西

信息:欢迎来到Appium V1.4.12(Rev 8db2d00b9afcf2c50a09a80a2e8d56b05a902caf)
信息:Appium Retth互联侦听器启动0.0.0.0:4723
信息:控制台Loglevel:调试

2评论:

  1. 嗨,在运行命令后,我陷入了第7步"brew link node". I'我被告知有以下错误。
    ---------------------------------------
    Amrutha @ Amrutha-Inspiron-3558:〜$ Brew链接节点
    错误:没有这样的keg:/home/amrutha/.linuxbrew/cellar/node
    Amrutha @ Amrutha-Inspiron-3558:
    ------------------------------

    你能帮忙解决这个问题吗?

    回复删除
  2. It'是一个很好的文章,你在这里分享了"如何在Ubuntu上安装Appium"。您的文章对于那些希望以实惠的价格购买此服务的人非常有用。我想感谢在这里分享这篇文章。 Ubuntu设置静态IP

    回复删除